using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[a-fA-F0-9]{2}:){5}[a-fA-F0-9]{2}";
string input = @"9hin00:1b:63:84:45:e6n0hu";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}