package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:[a-fA-F0-9]{2}:){5}[a-fA-F0-9]{2}`)
var str = `9hin00:1b:63:84:45:e6n0hu`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}