import Foundation
let pattern = #"(?:[a-fA-F0-9]{2}:){5}[a-fA-F0-9]{2}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"9hin00:1b:63:84:45:e6n0hu"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}