package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)[^a-zA-Z0-9 -]`)
var str = `hey! thsi is am@&4$amazing!`
var substitution = "-"
fmt.Println(re.ReplaceAllString(str, substitution))
}