const regex = /[^a-zA-Z0-9 -]/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^a-zA-Z0-9 -]', 'gmi')
const str = `hey! thsi is am@&4\$amazing!`;
const subst = `-`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);