re = /[^a-zA-Z0-9 -]/mi
str = 'hey! thsi is am@&4$amazing!'
subst = '-'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result