import Foundation
let pattern = #"[^a-zA-Z0-9 -]"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"hey! thsi is am@&4$amazing!"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"-"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)