#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)^.*?:\s*|[a-zA-Z]+,"
Local $sString = " Date: April 1st, 2015" & @CRLF & _
" Date: March 31st, 2015" & @CRLF & _
" Date: March 26th, 2015"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)