package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^.*?:\s*|[a-zA-Z]+,`)
var str = ` Date: April 1st, 2015
Date: March 31st, 2015
Date: March 26th, 2015`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}