re = /^.*?:\s*|[a-zA-Z]+,/mi
str = ' Date: April 1st, 2015
Date: March 31st, 2015
Date: March 26th, 2015'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result