const regex = /^.*?:\s*|[a-zA-Z]+,/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*?:\\s*|[a-zA-Z]+,', 'gmi')
const str = ` Date: April 1st, 2015
Date: March 31st, 2015
Date: March 26th, 2015`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);