#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\s'|'\s"
Local $sString = "Joe can't tell between 'large' and large."
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)