use strict;
my $str = 'Joe can\'t tell between \'large\' and large.';
my $regex = qr/\s'|'\s/p;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";