$re = '/\s\'|\'\s/';
$str = 'Joe can\'t tell between \'large\' and large.';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;