re = /\s'|'\s/
str = 'Joe can\'t tell between \'large\' and large.'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result