#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(['"])[^'"]*\1"
Local $sString = "abcdef"qy25347809 vb\:{}hf" vbnc," & @CRLF & _
"'hfgdb xhhn/dh84%' dkhaiuohrea" & @CRLF & _
"skjf skjbfz cjxclkjnds;kl'sdj hdhkbs*&hd9)'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")