using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(['""])[^'""]*\1";
string input = @"abcdef""qy25347809 vb\:{}hf"" vbnc,
'hfgdb xhhn/dh84%' dkhaiuohrea
skjf skjbfz cjxclkjnds;kl'sdj hdhkbs*&hd9)'";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}