$re = '/([\'"])[^\'"]*\1/mi';
$str = 'abcdef"qy25347809 vb\\:{}hf" vbnc,
\'hfgdb xhhn/dh84%\' dkhaiuohrea
skjf skjbfz cjxclkjnds;kl\'sdj hdhkbs*&hd9)\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);