re = /(['"])[^'"]*\1/mi
str = 'abcdef"qy25347809 vb\\:{}hf" vbnc,
\'hfgdb xhhn/dh84%\' dkhaiuohrea
skjf skjbfz cjxclkjnds;kl\'sdj hdhkbs*&hd9)\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end