using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^_.]+(?=\.)";
string input = @"REVIMER_F2-MARS3D-MENOR1200_20140809T0000Z.nc
ABC_XYZ_TESTTEXT.csv";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}