const regex = /[^_.]+(?=\.)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^_.]+(?=\\.)', 'gm')
const str = `REVIMER_F2-MARS3D-MENOR1200_20140809T0000Z.nc
ABC_XYZ_TESTTEXT.csv`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}