$re = '/[^_.]+(?=\.)/m';
$str = 'REVIMER_F2-MARS3D-MENOR1200_20140809T0000Z.nc
ABC_XYZ_TESTTEXT.csv';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);