re = /[^_.]+(?=\.)/m
str = 'REVIMER_F2-MARS3D-MENOR1200_20140809T0000Z.nc
ABC_XYZ_TESTTEXT.csv'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end