import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=/|^)(?!\\.\\.(?![^/]))[^/\\n]+/(?R)?\\.\\.(?:/|$)";
final String string = "folders/folder1/folder5/../../folder2\n"
+ " -> \"folders/folder2\"\n"
+ "folders/folder1/../../../folder2\n"
+ " -> \"../folder2\"\n"
+ "folders/folder1/folder5/../folder2\n"
+ " -> \"folders/folder1/folder2\"";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}