$re = '~(?<=/|^)(?!\.\.(?![^/]))[^/\n]+/(?R)?\.\.(?:/|$)~m';
$str = 'folders/folder1/folder5/../../folder2
-> "folders/folder2"
folders/folder1/../../../folder2
-> "../folder2"
folders/folder1/folder5/../folder2
-> "folders/folder1/folder2"';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;