using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-Za-z\.]+)\.D[0-9]{2}F[0-9]{2}";
string input = @"I.Want.This.Bit.D00F00.Non.Of.This";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}