package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([A-Za-z\.]+)\.D[0-9]{2}F[0-9]{2}`)
var str = `I.Want.This.Bit.D00F00.Non.Of.This`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}