$re = '/([A-Za-z\.]+)\.D[0-9]{2}F[0-9]{2}/';
$str = 'I.Want.This.Bit.D00F00.Non.Of.This';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);