const regex = /([A-Za-z\.]+)\.D[0-9]{2}F[0-9]{2}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([A-Za-z\\.]+)\\.D[0-9]{2}F[0-9]{2}', '')
const str = `I.Want.This.Bit.D00F00.Non.Of.This`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}