import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([a-z]){3}-([a-z]){3}-([a-z]){3}";
final String string = "5656\n"
+ "56565656565656565611\n"
+ "33434-2323-45\n"
+ "12-4345-12\n"
+ "123-456-789\n"
+ "abc-dec-gfh\n"
+ "jhf-wed-asf\n"
+ "abc\n"
+ "abc-dec\n"
+ "123-456\n"
+ "34453454351234566787\n"
+ "1234567890123-123456\n"
+ "1234567890123-12-56";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}