re = /^([a-z]){3}-([a-z]){3}-([a-z]){3}/m
str = '5656
56565656565656565611
33434-2323-45
12-4345-12
123-456-789
abc-dec-gfh
jhf-wed-asf
abc
abc-dec
123-456
34453454351234566787
1234567890123-123456
1234567890123-12-56'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end