// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([a-z]){3}-([a-z]){3}-([a-z]){3}").unwrap();
let string = "5656
56565656565656565611
33434-2323-45
12-4345-12
123-456-789
abc-dec-gfh
jhf-wed-asf
abc
abc-dec
123-456
34453454351234566787
1234567890123-123456
1234567890123-12-56";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}