const regex = /^([a-z]){3}-([a-z]){3}-([a-z]){3}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([a-z]){3}-([a-z]){3}-([a-z]){3}', 'gm')
const str = `5656
56565656565656565611
33434-2323-45
12-4345-12
123-456-789
abc-dec-gfh
jhf-wed-asf
abc
abc-dec
123-456
34453454351234566787
1234567890123-123456
1234567890123-12-56`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}