package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?: )+([^<]*)`)
var str = `<ul class="columns">
<li><u>Running costs</u></li>
<li>Urban mpg 50.4 mpg</li>
<li>Extra Urban mpg 72.4 mpg</li>
</ul>`
var substitution = "<span class="right">\1</span>"
fmt.Println(re.ReplaceAllString(str, substitution))
}