use strict;
my $str = '<ul class="columns">
<li><u>Running costs</u></li>
<li>Urban mpg 50.4 mpg</li>
<li>Extra Urban mpg 72.4 mpg</li>
</ul>';
my $regex = qr/(?: )+([^<]*)/p;
my $subst = '<span class="right">\\1</span>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";