$re = '/(?: )+([^<]*)/';
$str = '<ul class="columns">
<li><u>Running costs</u></li>
<li>Urban mpg 50.4 mpg</li>
<li>Extra Urban mpg 72.4 mpg</li>
</ul>';
$subst = "<span class=\"right\">\1</span>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;