const regex = /(\b\S+\b)(?=.*\b\1\b.*), /;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\b\\S+\\b)(?=.*\\b\\1\\b.*), ', '')
const str = `"Arizona, Arizona, Arizona, California Carmel Beach, California LBC, California Napa, Arizona"
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}