import Foundation
let pattern = #"(\b\S+\b)(?=.*\b\1\b.*), "#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
"Arizona, Arizona, Arizona, California Carmel Beach, California LBC, California Napa, Arizona"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}