re = /(\b\S+\b)(?=.*\b\1\b.*), /
str = '"Arizona, Arizona, Arizona, California Carmel Beach, California LBC, California Napa, Arizona"
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end