$re = '/(\b\S+\b)(?=.*\b\1\b.*), /';
$str = '"Arizona, Arizona, Arizona, California Carmel Beach, California LBC, California Napa, Arizona"
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);