#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*[0-9])(?=.*[a-z])(?=.*[A-Z])(?=.*[!@#$%^&+=])(?=.{10,16})$"
Local $sString = "1a3@56A89" & @CRLF & _
"1a3@56A890" & @CRLF & _
"1a3@56A8901" & @CRLF & _
"1a3@56A89012" & @CRLF & _
"1a3@56A890123" & @CRLF & _
"1a3@56A8901234" & @CRLF & _
"1a3@56A89012345" & @CRLF & _
"1a3@56A890123456" & @CRLF & _
"1a3@56A8901234567" & @CRLF & _
"1a3@56A8901234568" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")