use strict;
my $str = '1a3@56A89
1a3@56A890
1a3@56A8901
1a3@56A89012
1a3@56A890123
1a3@56A8901234
1a3@56A89012345
1a3@56A890123456
1a3@56A8901234567
1a3@56A8901234568
';
my $regex = qr/^(?=.*[0-9])(?=.*[a-z])(?=.*[A-Z])(?=.*[!@#$%^&+=])(?=.{10,16})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}