import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*[0-9])(?=.*[a-z])(?=.*[A-Z])(?=.*[!@#$%^&+=])(?=.{10,16})$";
final String string = "1a3@56A89\n"
+ "1a3@56A890\n"
+ "1a3@56A8901\n"
+ "1a3@56A89012\n"
+ "1a3@56A890123\n"
+ "1a3@56A8901234\n"
+ "1a3@56A89012345\n"
+ "1a3@56A890123456\n"
+ "1a3@56A8901234567\n"
+ "1a3@56A8901234568\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}