$re = '/^(?=.*[0-9])(?=.*[a-z])(?=.*[A-Z])(?=.*[!@#$%^&+=])(?=.{10,16})$/m';
$str = '1a3@56A89
1a3@56A890
1a3@56A8901
1a3@56A89012
1a3@56A890123
1a3@56A8901234
1a3@56A89012345
1a3@56A890123456
1a3@56A8901234567
1a3@56A8901234568
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);