#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[1-9]\d{1,2},\d{3}|[1-9]\d{0,2}(?:,\d{3}){2,})$"
Local $sString = "10,000" & @CRLF & _
"100,000" & @CRLF & _
"999,999" & @CRLF & _
"1,000,000" & @CRLF & _
"10,000,000" & @CRLF & _
"" & @CRLF & _
"9,999" & @CRLF & _
"010,000" & @CRLF & _
"10000" & @CRLF & _
"100,00" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")