import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[1-9]\\d{1,2},\\d{3}|[1-9]\\d{0,2}(?:,\\d{3}){2,})$";
final String string = "10,000\n"
+ "100,000\n"
+ "999,999\n"
+ "1,000,000\n"
+ "10,000,000\n\n"
+ "9,999\n"
+ "010,000\n"
+ "10000\n"
+ "100,00\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}