import re
regex = re.compile(r"^(?:[1-9]\d{1,2},\d{3}|[1-9]\d{0,2}(?:,\d{3}){2,})$", flags=re.MULTILINE)
test_str = ("10,000\n"
"100,000\n"
"999,999\n"
"1,000,000\n"
"10,000,000\n\n"
"9,999\n"
"010,000\n"
"10000\n"
"100,00\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")