$re = '`^(?:[1-9]\d{1,2},\d{3}|[1-9]\d{0,2}(?:,\d{3}){2,})$`m';
$str = '10,000
100,000
999,999
1,000,000
10,000,000
9,999
010,000
10000
100,00
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);