# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([^a])aa([^a])/$1abcd$2/gm;t' <<< "#aa
.aa
#aa>
#aa{
#aa+
#aa
#aa{
#aaa{
test#aa{"