package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^a])aa([^a])`)
var str = `#aa
.aa
#aa>
#aa{
#aa+
#aa
#aa{
#aaa{
test#aa{`
var substitution = "$1abcd$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}